US DC - Pricing slowness – Incident details

All systems operational

Pricing slowness

Resolved
Degraded performance
Started 25 days agoLasted about 1 hour

Affected

Pricing

Degraded performance from 1:55 PM to 2:53 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    We are currently experiencing degraded performance in our pricing service, which may cause delays in pricing updates. All services remain operational and pricing is continuing to run, but some updates may take longer than usual. We are continuing to work on a fix.